Forge not working for some accounts

  • I play on server 38 and I think that there are some problems, but only with some accounts.

    I am lvl 93 and am trying to forge items for 1 month now. I have 12 failed attempts out of 12 tries. My tries were something like this:

    - 2-3 tries with 65% success chance

    - 6-7 tries with 75%

    - 3 tries with 85%

    Then I asked a guild mate to smelt 2 items for me just to make a test and he tried with 50% and 60%. Both of them worked.

    I don't think the problem is pure bad luck because this is statistically very unlikely.

    So I think my account could be in some way flagged and not able to ever forge anything. I was banned for one day because of insulting another player(after he insulted me first, but what can you do).

    Another guess as to why this would be would be that the game sees that I have a lot of gems and that I am not spending 70%-80% of them on a forge try. PS: I used multiple times 200 gems(2 golden tools) but with no success.

    Did someone else run into this kind of issue? I am really frustrated about this.

  • hey guys


    sorry I`m a bit late with answering. first question, which community was effexted? s38 cant be a server from EE.


    second, did someone write a ticket?

  • The province is 38, but I didn't know what to pick when I wrote the post so I selected EE :).

    I wrote a ticket also, but received an answer that it's just bad luck.

    After I wrote the post I tried another 2 blue items just to make some more tests. The first one was about 80% and it failed, the second one was 40% and that one actually worked. The one that had by far the lowest percent to succeed worked. Maybe the percentages and reversed :)